summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJustin Worthe <justin@worthe-it.co.za>2017-09-10 21:58:50 +0200
committerJustin Worthe <justin@worthe-it.co.za>2017-09-10 21:58:50 +0200
commit9f381cd26fee3926ac0128772e23f6e00681e4e1 (patch)
treea20558f8155cff05ac01929bf51fca802e7be684 /Cargo.toml
parentd23fae9da3da625ca87c615a7798570f138aa0f5 (diff)
Added compile flags to disable anything that shouldn't end in a wasm build
- No GTK - No Portaudio
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cb31267..95dee5f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,10 +4,12 @@ version = "0.1.0"
authors = ["Justin Worthe <justin.worthe@gmail.com>"]
[dependencies]
+bencher = "0.1.2"
+
+[target.'cfg(not(target_os = "emscripten"))'.dependencies]
portaudio = "0.7.0"
gtk = "0.1.1"
cairo-rs = "0.1.1"
-bencher = "0.1.2"
[[bench]]
name = "transforms"