summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 10 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2d5d33e..f255a9f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,9 +2,15 @@
name = "qif_parser"
version = "0.1.0"
authors = ["Justin Worthe <justin@worthe-it.co.za>"]
+edition = "2018"
[dependencies]
-regex = "0.2.2"
-lazy_static = "1.0"
-structopt = "0.1.6"
-structopt-derive = "0.1.6" \ No newline at end of file
+regex = "1.7"
+lazy_static = "1"
+clap = { version = "4.1", features = ["derive"] }
+
+[profile.dev.package."*"]
+opt-level = 3
+# incremental compile is rarely useful for dependencies since they change
+# infrequently, and having this on breaks sccache
+incremental = false