summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJustin Worthe <justin@worthe-it.co.za>2018-05-13 19:09:26 +0200
committerJustin Worthe <justin@worthe-it.co.za>2018-05-13 19:09:26 +0200
commitdd78789f242814bc750d886cc2d0c8f0877ade7c (patch)
tree049e9f24ec0b00c585fb21033525adb168b39405 /Cargo.toml
parent02256124fbd57d88effd02c046093ecaf73b77e3 (diff)
Added initial benchmarks
There's a lot of room for improvement here. Specifically, I should separate the internal representation from the test interface. Have it provide functionality for creating random valid states.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 9 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7703fc6..01abf5d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,4 +8,12 @@ serde = "1.0.43"
serde_json = "1.0.16"
rand = "0.4.2"
-time = "0.1.4" \ No newline at end of file
+time = "0.1.4"
+
+[dev-dependencies]
+criterion = "0.2"
+lazy_static = "1.0"
+
+[[bench]]
+name = "engine"
+harness = false \ No newline at end of file