summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJustin Wernick <justin@worthe-it.co.za>2023-05-28 22:40:21 +0200
committerJustin Wernick <justin@worthe-it.co.za>2023-05-28 22:40:21 +0200
commitf129dadf8ce4971f794ae325f610be3e8fdcbea8 (patch)
tree46b52d6fc31f22cf76886666b362bfc0e71ee7e9 /Cargo.toml
parent9ad50b6aeb13bc449e4f6e596dd91e79338f070e (diff)
Cargo-dist config for building releases
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 13 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 521add9..f975549 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -39,3 +39,16 @@ incremental = false
[profile.release]
lto = true
+
+# The profile that 'cargo dist' will build with
+[profile.dist]
+inherits = "release"
+
+# Config for 'cargo dist'
+[workspace.metadata.dist]
+# The preferred cargo-dist version to use in CI (Cargo.toml SemVer syntax)
+cargo-dist-version = "0.0.7"
+# The preferred Rust toolchain to use in CI (rustup toolchain syntax)
+rust-toolchain-version = "1.67.1"
+# Target platforms to build apps for (Rust target-triple syntax)
+targets = ["x86_64-unknown-linux-gnu"]