summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJustin Wernick <justin@worthe-it.co.za>2023-03-12 01:13:05 +0200
committerJustin Wernick <justin@worthe-it.co.za>2023-03-12 01:13:05 +0200
commit87359e99233a61abbf9f8e424eba486fe53e9cfd (patch)
tree72d7b4e059c3262c72751a2cd3eaba0296ccc678 /Cargo.toml
parent85d187133ddcea5284529bc57caaa7f66f73ab95 (diff)
Make sure ssh ports don't conflict between tests
There were race conditions here since it previously checked with the OS if the port was in use yet.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5e76338..75dec3a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,4 +15,5 @@ thiserror = "1.0.38"
anyhow = "1.0.69"
assert_cmd = "2.0.8"
get-port = "4.0.0"
+once_cell = "1.17.1"
tempfile = "3.4.0"