summaryrefslogtreecommitdiff
path: root/keyboards/cannonkeys/gentoo_hs/rules.mk
diff options
context:
space:
mode:
authorAndrew Kannan <andrew.kannan@gmail.com>2022-07-02 18:18:43 -0400
committerGitHub <noreply@github.com>2022-07-02 23:18:43 +0100
commit43e33ba232a02f627c4fcc6607edd6f7971e71b8 (patch)
treee3bf31e4513fa08c04cdaeb8c1e3fa3fad6474a5 /keyboards/cannonkeys/gentoo_hs/rules.mk
parent2011aec06f17fd9c80aba740cca82ec5b85759cc (diff)
Add Gentoo Hotswap PCB to QMK (#17528)
Diffstat (limited to 'keyboards/cannonkeys/gentoo_hs/rules.mk')
-rw-r--r--keyboards/cannonkeys/gentoo_hs/rules.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/keyboards/cannonkeys/gentoo_hs/rules.mk b/keyboards/cannonkeys/gentoo_hs/rules.mk
new file mode 100644
index 0000000000..b34d15f4b5
--- /dev/null
+++ b/keyboards/cannonkeys/gentoo_hs/rules.mk
@@ -0,0 +1,24 @@
+# MCU name
+MCU = STM32F072
+
+# Bootloader selection
+BOOTLOADER = stm32-dfu
+
+# Wildcard to allow APM32 MCU
+DFU_SUFFIX_ARGS = -v FFFF -p FFFF
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = yes # Enable Bootmagic Lite
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = yes # Console for debug
+COMMAND_ENABLE = yes # Commands for debug and configuration
+NKRO_ENABLE = yes # Enable N-Key Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+AUDIO_ENABLE = no # Audio output
+
+# Enter lower-power sleep mode when on the ChibiOS idle thread
+OPT_DEFS += -DCORTEX_ENABLE_WFI_IDLE=TRUE