summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Worthe <justin.worthe@gmail.com>2015-06-08 20:28:34 +0200
committerJustin Worthe <justin.worthe@gmail.com>2015-06-08 20:28:34 +0200
commit0ef4646a9c19d3d88ffb7674123ccdc0a9012d98 (patch)
tree9504a288bb693bd1db6fbade32a76174294faa53 /CMakeLists.txt
parent7073d9f97b54f41d227b960d05dd28af74d5776d (diff)
Added build for test project
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 525c1ce..97c6647 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,4 +6,10 @@ set(CMAKE_CXX_FLAGS "-std=c++11")
include_directories(${PROJECT_SOURCE_DIR}/include)
file(GLOB_RECURSE SRC_FILES RELATIVE ${PROJECT_SOURCE_DIR} src/*.cpp)
-add_executable(cppbot ${SRC_FILES})
+file(GLOB_RECURSE MAIN_FILES RELATIVE ${PROJECT_SOURCE_DIR} main/*.cpp)
+add_executable(cppbot ${SRC_FILES} ${MAIN_FILES})
+
+enable_testing()
+file(GLOB_RECURSE TEST_FILES RELATIVE ${PROJECT_SOURCE_DIR} test/*.cpp)
+add_executable(cppbot_test ${SRC_FILES} ${TEST_FILES})
+add_test(Tests cppbot_test)