summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Worthe <justin.worthe@gmail.com>2015-05-19 19:56:41 +0200
committerJustin Worthe <justin.worthe@gmail.com>2015-05-19 19:56:41 +0200
commit08365e5558d800e108b2d377cf6c03397d1ff2c2 (patch)
tree8198c1132be26af9672d38a572bca0fcea87d89c /CMakeLists.txt
Initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..7881e49
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,7 @@
+cmake_minimum_required(VERSION 3.2.2)
+project(cppbot)
+
+include_directories(${PROJECT_SOURCE_DIR}/include)
+
+file(GLOB_RECURSE SRC_FILES RELATIVE ${PROJECT_SOURCE_DIR} src/*.cpp)
+add_executable(cppbot ${SRC_FILES})