summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAndré Silva <123550+andresilva@users.noreply.github.com>2021-01-14 19:29:00 +0000
committerDrashna Jael're <drashna@live.com>2021-02-02 09:39:43 -0800
commit0719cda8514df3d2d361667aff577d28f67e1f09 (patch)
treef4ccb3791c9bd1978988f97055ddff03cb0cc65b /shell.nix
parent97b1e6faf820b82765fae3eefda9760dbc23fc19 (diff)
allow customizing decrease delay of rgb heatmap (#11322)
* allow customizing decrease delay of rgb heatmap * rename rgb typing heatmap decrease delay variable * address review comments * nix-shell: add clang-tools required for formatting the C code * heatmap: use real timer to track decrement rate * heatmap: fix ifndef var name typo * heatmap: add docs * Update docs/feature_rgb_matrix.md Co-authored-by: Drashna Jaelre <drashna@live.com> Co-authored-by: Drashna Jaelre <drashna@live.com>
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 6cfda2da9a..82505d5d27 100644
--- a/shell.nix
+++ b/shell.nix
@@ -71,7 +71,7 @@ in
mkShell {
name = "qmk-firmware";
- buildInputs = [ dfu-programmer dfu-util diffutils git pythonEnv ]
+ buildInputs = [ clang-tools dfu-programmer dfu-util diffutils git pythonEnv ]
++ lib.optional avr [
pkgsCross.avr.buildPackages.binutils
pkgsCross.avr.buildPackages.gcc8