summaryrefslogtreecommitdiff
path: root/nix/pyproject.toml
diff options
context:
space:
mode:
authorSteve Purcell <steve@sanityinc.com>2021-04-04 03:05:46 +1200
committerGitHub <noreply@github.com>2021-04-03 08:05:46 -0700
commitd91938c19dd65af88713b9deffe95794ed78e889 (patch)
tree9fdca00bdbb1a90ffc1245c173589bbaa3b780e5 /nix/pyproject.toml
parenta3cd1290be8187a34e3c4e156c07531380bfecaa (diff)
[nix] Use niv and poetry2nix to more easily manage dependencies (#11181)
* [nix] Update nixpkgs to avoid issues with Big Sur The older nixpkgs snapshot did not contain nix changes to the compiler/linker hooks that are necessary for compatibility with MacOS Big Sur. The fix is simply to update to a newer snapshot. * [nix] Add a poetry manifest and use poetry to build the Python env * [nix] Use niv to manage upstream sources like nixpkgs * [nix] Update to newer nixpkgs snapshot * [nix] Bump python package versions
Diffstat (limited to 'nix/pyproject.toml')
-rw-r--r--nix/pyproject.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/nix/pyproject.toml b/nix/pyproject.toml
new file mode 100644
index 0000000000..62d49fad59
--- /dev/null
+++ b/nix/pyproject.toml
@@ -0,0 +1,30 @@
+# This file should be kept in sync with requirements.txt and requirements-dev.txt
+# It is particularly required by the Nix environment (see shell.nix). To update versions,
+# normally one would run "poetry update --lock"
+[tool.poetry]
+name = "qmk"
+version = "0.1.0"
+description = ""
+authors = []
+
+[tool.poetry.dependencies]
+python = "^3.8"
+appdirs = "^1.4.4"
+argcomplete = "^1.12.2"
+colorama = "^0.4.4"
+hjson = "^3.0.2"
+milc = "^1.1.0"
+Pygments = "^2.8.0"
+dotty-dict = "^1.3.0"
+jsonschema = "^3.2.0"
+
+[tool.poetry.dev-dependencies]
+nose2 = "^0.10.0"
+flake8 = "^3.8.4"
+pep8-naming = "^0.11.1"
+yapf = "^0.30.0"
+Wave = "^0.0.2"
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"