summaryrefslogtreecommitdiff
path: root/keyboards/aurora65/rules.mk
diff options
context:
space:
mode:
authoryiancar <yiangosyiangou@cytanet.com.cy>2022-08-10 21:07:41 +0100
committerGitHub <noreply@github.com>2022-08-10 21:07:41 +0100
commita6d0cc3aab7182278e8765d6968775ca9e320392 (patch)
tree1057cc0367551d170cbe7552f32c3c1bdc6ec413 /keyboards/aurora65/rules.mk
parent8a24fbbdaea4f3ff9bdcdf76036bedca6e335bce (diff)
Aurora65 (#17966)
* aurora65 initial commit * Add keymap images * Move USB config to JSON Co-authored-by: yiancar <yiancar@gmail.com>
Diffstat (limited to 'keyboards/aurora65/rules.mk')
-rw-r--r--keyboards/aurora65/rules.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/keyboards/aurora65/rules.mk b/keyboards/aurora65/rules.mk
new file mode 100644
index 0000000000..fc545388a3
--- /dev/null
+++ b/keyboards/aurora65/rules.mk
@@ -0,0 +1,29 @@
+# MCU name
+MCU = STM32F072
+
+# Bootloader selection
+BOOTLOADER = stm32-dfu
+
+# Wildcard to allow APM32 MCU
+DFU_SUFFIX_ARGS = -v FFFF -p FFFF
+
+# Do not put the microcontroller into power saving mode
+# when we get USB suspend event. We want it to keep updating
+# backlight effects.
+OPT_DEFS += -DCORTEX_ENABLE_WFI_IDLE=TRUE
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = yes # Enable Bootmagic Lite
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+NKRO_ENABLE = yes # Enable N-Key Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = yes # Enable keyboard RGB underglow
+WS2812_DRIVER = pwm # Driver for RGB uderglow
+AUDIO_ENABLE = no # Audio output
+
+LAYOUTS = 65_ansi_blocker