summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 9 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index bcb0dda..f441308 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,11 +1,11 @@
[package]
name = "capn"
-version = "0.5.1"
+version = "0.5.2"
authors = ["Justin Wernick <justin@jemstep.com>"]
edition = "2018"
[dependencies]
-git2 = { version = "0.8.0", default-features = false }
+git2 = { version = "0.13.0", default-features = false }
structopt = "0.3.5"
serde = { version = "1.0.89", features = ["derive"] }
toml = "0.5.5"
@@ -17,4 +17,10 @@ uuid = { version = "0.8.1", features = ["serde", "v4"] }
[dev-dependencies]
quickcheck = "0.9.2"
-quickcheck_macros = "0.9.1" \ No newline at end of file
+quickcheck_macros = "0.9.1"
+
+[profile.release]
+
+# Turns Link-Time Optimization up to the MAX! Results in slower
+# release build times, but faster and significantly smaller binaries.
+lto = true