Renamed variable to be more concise
[entelect-challenge-tower-defence.git] / Cargo.toml
1 [package]
2 name = "zombot"
3 version = "3.0.0"
4
5 [dependencies]
6 serde_derive = "1.0.71"
7 serde = "1.0.71"
8 serde_json = "1.0.26"
9
10 rand = "0.5.5"
11 time = "0.1.4"
12 rayon = "1.0.2"
13
14 arrayvec = "0.4.7"
15
16 lazy_static = { version = "1.1.0", optional = true }
17
18 [dev-dependencies]
19 proptest = "0.8.4"
20
21 [features]
22 benchmarking = []
23 single-threaded = []
24 debug-decisions = []
25 reduced-time = []
26 extended-time = []
27
28 energy-cutoff = []
29 discard-poor-performers = []
30 heuristic-random = ["lazy_static"]
31 full-monte-carlo-tree = []
32 static-opening = []
33 weighted-win-ratio = []
34
35 default = ["energy-cutoff", "discard-poor-performers", "static-opening", "weighted-win-ratio"]
36
37 [profile.release]
38 debug = true